Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 15, 2024 - 16:30 CST
Scheduled
Please be aware that mycloud services will be unavailable for 45 minutes as our technical team will be performing scheduled server maintenance for Sprint 1.0.1.4.4.
This period of downtime is used for necessary updates and installing some exciting new features to our mycloud system. Please plan for this by printing any information you may need during those down hours (check-in, check-out, invoices, schedules & necessary reports). We apologize for any inconvenience.
Posted Nov 15, 2024 - 00:53 CST
This scheduled maintenance affected: mycloud PMS, mycloud POS, mycloud Channel Manager, mycloud Accounts, mycloud Contactless Web App, mycloud Store & Inventory, mycloud Central Reservation System (CRS), mycloud Guest Services, and mycloud Banquet.