Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 31, 2025 - 18:30 CDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 31, 2025 - 03:36 CDT
Scheduled
Please be aware that mycloud services will be unavailable for 60 minutes as our technical team will be performing scheduled server maintenance for security patches.
During this time, you will be unable to log in to mycloud Application. Before maintenance takes place, please make sure you print the necessary invoices and reports that may be required.
We appreciate your cooperation in building a more advanced and sustainable hotel technology platform. If you require any assistance, please reach out to support@mycloudhospitality.com.
Posted Mar 31, 2025 - 18:30 CDT
This scheduled maintenance affected: mycloud PMS, mycloud POS, mycloud Channel Manager, mycloud Accounts, mycloud Contactless Web App, mycloud Store & Inventory, mycloud Central Reservation System (CRS), mycloud Guest Services, and mycloud Banquet.